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About SSA Plugin 

 

The user of this plugin is assumed to know fundamental knowledge about the space 

syntax analysis (SSA) and geographic information systems (GIS). The plugin basically 

calculates the basic space syntax parameters particularly for line networks (axial lines, 

named streets or segment based) and makes it possible for the user to export the 

produced adjusted graph and geodesics to a social network analysis (SNA) software 

program file format (dl or net file) for further analysis of the spatial configuration 

concerned in the respective SNA software programs. SSA Plugins have been particularly 

designed for FOSS4GIS and released under the GNU GPL v2 license as it is also stated 

in the explanations given at beginning of the scripts for this purpose. 

 

How to Install SSA Plugin 

 

The procedure to install SSA plugin in FOSS4GIS is quite simple. Once you copy the 

files or folder listed in Table 1 and Table 2 to the directory where the plugins are located, 

you can directly begin to use SSA plugin without any difficulty. Nevertheless the user 

will suddenly notice that in some FOSS4GIS, SSA plugin could not be run or activated 

without loading or selecting a vector layer covering information about a spatial 

configuration for which an adjusted graph will be produced and subsequently space 

syntax parameters will be calculated. 

 

After copying the files or folder to the location provided in Table 1 and Table 2, you 

should (re-)start FOSS4GIS you use. For OpenJUMP Jython SSA Plugin, existing 

startup.py and mystartup.py are modified to work with the plugin. Thus, if you are 

familiar with these files, instead of copying them directly to the plugin folder you can 

modify the respective files by analyzing the files attached to the plugin. In a similar 

fashion in Thuban, a thubanstart.py file is created in order to load SSA Plugin when the 

program starts. If you already have a thubanstart.py file, you should actually modify it by 

placing “import spacesyntax.py” inside it instead of copying thubanstart.py associated 

with the plugin to Thuban directory. 
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SSA plugin can be run in different FOSS4GIS via different menu options (see Table 3 

for the menu system and toolbar through which you can activate and run SSA Plugin in 

different FOSS4GIS). In some FOSS4GIS (gvSIG, Quantum GIS, MapWindow GIS and 

OpenJUMP Jython) the plugin can also be run via a toolbar. The tool image for the 

plugin is as following;  

 

SSA tool icon:   

 

In gvSIG there are two options for the plugin: (1) using Jython-Java GUI or (2) using 

xml GUI (see the images of GUIs given at the end of guide). It is up to you which one to 

choose. The only difference is between GUIs. In a different fashion, there are three 

options to install SSA plugin in OpenJUMP: (1) BeanShell script version, (2) Jython 

plugin version and (3) Java (jar) version. Although BeanShell version is very slow 

compared with Jython and Java version, you may prefer to use the respective version in 

order to see and test how the scripts work. Jython version is again slow compared with 

Java version but it is easier and faster to produce scripts and plugins in Jython compared 

with Java for which you need a development platform and compiler such as Eclipse. 

 

Users may also experience some problems in installing and running the plugin for SAGA 

GIS. SSA Plugin works fine on the platform where I compile “.dll” file for SAGA, but I 

noticed that it may not work in other computers lacking the development environment. 

Lastly for OrbisGIS and R Statistical Package I only provide you with SSA scripts that 

should be manually loaded to the software each time you employ it. 
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Table 1. SSA Plugin files or folder to copy and the location of plugin directory for different FOSS4GIS (Windows): 

 

FOSS4GIS Files or folder to copy Where to paste the files or folder (plugin directory) 

OpenJUMP – BeanShell Space Syntax Analysis.bsh C:\Program Files\OpenJUMP\lib\ext\BeanTools 

OpenJUMP – Jython startup.py, mystartup.py, SpaceSyntax.py  C:\Program Files\OpenJUMP\lib\ext\jython 

OpenJUMP – Java spacesyntax.jar C:\Program Files\OpenJUMP\lib\ext 

gvSIG – Jython GUI SSA folder C:\Program Files\gvSIG_1.9\bin\gvSIG\extensiones 

gvSIG – xml GUI SpaceSyntax folder C:\Program Files\gvSIG_1.9\bin\gvSIG\extensiones 

Thuban – Python thubanstart.py, spacesyntax.py C:\Program Files\Thuban 

OpenEV – Python spacesyntax.py C:\Program Files\FWTools2.4.7\tools 

Quantum GIS – Python spacesyntax folder C:\Program Files\Quantum GIS Wroclaw\apps\qgis\python\plugins 

MapWindow GIS – VB.Net SpaceSyntax folder C:\Program Files\MapWindow\Plugins 

SAGA GIS – C++ SpaceSyntax.dll C:\Program Files\SAGA-GIS\modules 

OrbisGIS – BeanShell Space Syntax Analysis.bsh anywhere you like (you need to load the script) 

R Project Space Syntax Analysis.r anywhere you like (you need to load the script) 
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Table 2. SSA Plugin files or folder to copy and the location of plugin directory for different FOSS4GIS (Ubuntu): 

 

FOSS4GIS Files or folder to copy Where to paste the files or folder (plugin directory) 

OpenJUMP – BeanShell Space Syntax Analysis.bsh /usr/share/openjump/ext /BeanTools 

OpenJUMP – Jython startup.py, mystartup.py, SpaceSyntax.py  /usr/share/openjump/ext /jython 

OpenJUMP – Java spacesyntax.jar /usr/share/openjump/ext 

gvSIG – Jython GUI SSA folder …/gvSIG/extensiones 

gvSIG – xml GUI SpaceSyntax folder …/gvSIG/extensiones 

Thuban – Python thubanstart.py, spacesyntax.py …/thuban 

OpenEV – Python spacesyntax.py …/tools 

Quantum GIS – Python spacesyntax folder /usr/share/qgis/python/plugins/ 

OrbisGIS – BeanShell Space Syntax Analysis.bsh any where you like (you need to load the script) 

R Project Space Syntax Analysis.r any where you like (you need to load the script) 
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Table 3. Menu items and toolbar through which SSA Plugin can be activated and run in 

different FOSS4GIS: 

 

FOSS4GIS Menu path to run SSA plugin 

OJ – BeanShell Customize → BeanTools → Space Syntax Analysis 

OJ – Jython 
Customize → Python Console and Tools... (activate Jython menu-tool) 

Tools → Space Syntax Analysis  

OJ – Java Graph Theoretic → Space Syntax Analysis 

gvSIG  File → Scripting → Space Syntax Analysis 

Thuban Space Syntax Analysis → Space Syntax Analysis 

OpenEV Tools → Space Syntax Analysis 

Quantum GIS Plugins → Space Syntax Analysis → Space Syntax Analysis 

MapWindow GIS by clicking SSA Plugin icon on “SpaceSyntax” toolbar 

SAGA GIS 
Modules → Shapes → Space Syntax Analysis (or) 

Module Libraries → Space Syntax Analysis Module → Space Syntax Analysis 

OrbisGIS 
View → Beanshell Console (activate BeanShell Console) 

bsh script can be loaded and run via BeanShell Console 

R Project File → Open Script… (you can load and run R script) 

 

Before running SSA Plugin, in some FOSS4GIS you are required to activate or load it. In 

this respect both in Quantum GIS and MapWindow GIS, you should first activate the 

plugin via the proper menu. In QGIS you can enable SSA Plugin via “Plugins → Manage 

Plugins…”. Once you active the plugin it can be run via both Menu bar and Plugin 

toolbar. In MapWindow GIS, you can activate SSA Plugin icon via directly selecting 

“Plug-ins → Space Syntax Analysis” or “Plug-ins → Edit Plug-ins” where you can get 

some extra information about the plugin (such as author and version number). In some 

FOSS4GIS, plugin can be run after activating another tool. For example in OpenJUMP in 

order to run Jython SSA plugin you are first required to activate Jython menu and tool 

bar, and then you can select SSA via either “Tools - Space Syntax Analysis” or SSA text 

icon placed on the Jython toolbar. 
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How to Use SSA Plugin 

 

Once you select the menu item or click the toolbar icon provided for SSA Plugin, a 

dialog box appears in the window as a Graphical User Interface (GUI) in order to make it 

possible for you to activate the options in relation to the outcomes of space syntax 

analysis in addition to the calculation of basic space syntax parameters. If no option is 

selected via GUI, plugin assigns a sequential number to each feature (currently lines or 

regions) and calculates the following parameters for a given spatial configuration (see 

Hillier and Hanson (2003) for the elaboration of the respective parameters, and see 

Beyhan (2011 and 2012) for the operationalization of them as a SSA plugin for 

FOSS4GIS): 

 

Parameters calculated by SSA Plugin: Graphical User Interface of the plugin: 

For each feature in a vector layer; 

• Connectivity,  

• Total Depth,  

• Mean Depth,  

• Global Integration,  

• Local Depth, 

• Local Integration, 

• Control Value. 

 

For the whole spatial configuration; 

• Intelligibility value 

 

 

If user checks the option “Calculate intelligibility value”, in addition to the above 

parameters plugin also calculates the Pearson Correlation (i.e. intelligibility value) 
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between connectivity and global integration. For those who are willing to calculate graph 

theoretic parameters other than the ones available in a standard SSA software including 

the ones offered in this plugin, extra option is available to transfer the adjusted graph 

created by the plugin to an external file (Ucinet’s “.dl” or Pajek’s “.net” format) that can 

be further processed in the software programs specifically designed for social network 

analysis (SNA) (such as ORA (Organizational Risk Analyzer), Pajek, Ucinet, visone, and 

socnetv). For this purpose, you should mark “Create network data:” option that makes it 

possible for you to choose a file format to save the resulting adjusted graph. 

 

Once you save the adjusted graph in a SNA file format, you can easily open the 

respective network data, for example, in ORA and conduct further analysis (such as 

calculation of other measures of centrality including closeness, betweenness, authority, 

hub and information centrality). The new parameters calculated in ORA can later be 

transferred to FOSS4GIS by saving the results to a “.csv” or “.txt” file that can easily be 

linked to the original spatial data in GIS via the proper procedure available to connect an 

external tabular data to the existing attribute table. 

 

You can also write the geodesic matrix to a text (“.txt”) file if you mark the option for 

“Create geodesic matrix.” Once the user chooses any of the options available for the 

creation of an external file that can be used in other software programs particularly 

developed for social network analysis, plugin also asks for the matrix headings that will 

appear in the output files. In this respect, two options are available for the matrix headings;  

 

(1) employment of the internal index that range between 1 and the number of 

features involved in the network, 

 

(2) employment of a field in the attribute table as the matrix headings.  

 

What is particularly important for the second option is the fact that the field chosen for 

the matrix heading should not include duplicate IDs (identity numbers) for (line or 

polygon) features. If you choose to use a field from the attribute table, you are asked to 

provide the respective field. Irrespective of the users’ choice, the internal IDs of the 
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features (Lineno) are also added to the new attribute table in addition to the space syntax 

parameters in order to make it possible for the users to re-integrate the parameters 

calculated outside FOSS4GIS to the attribute table. 

 

If the option available to “Save the file(s) in a different location” is checked, you are 

asked to provide location and name of the file that will store the adjusted graph or 

geodesic distance. Otherwise, the files created for adjusted graph and geodesic distance 

are saved in the directory where the source layer is located by using the name of the 

source layer if the respective options are marked to produce output files. 

 

The GUI given above in the sixth page is almost standard for all FOSS4GIS for which a 

SSA plugin or script is developed by the author except for Thuban and R Project where 

user is additionally asked for to provide a file name to which the output GIS file (“.shp”) 

will be written. Except for Thuban and R Project it was possible for the author to write the 

results of the analysis to either the attribute table of the layer selected to be analyzed or to a 

new layer (gvSIG only). However, in other FOSS4GIS users should also save the results of 

the analysis before they close FOSS4GIS they prefer to use. Otherwise, all the new 

information can be lost. In R, when the script is run, it first asks for the location of “.shp” 

file to be processed. After selecting “.shp” file, script constructs the adjusted graph and 

calculates geodesics by using sna package written by Butts (2010). After these calculations 

an option is also offered to the user via SSA GUI to calculate intelligibility value and to 

enter the radius for local value. And when you press OK, you are prompted to provide the 

location and name of the file to which the results of the analysis (parameters) will be 

written. Considering the existence of a social network analysis library (sna) in R Project, 

no option is created to export the adjusted graph to an external file in the respective 

software program. After running the script, user will already have the adjusted graph stored 

in a two dimensional array named as ‘sna’. By using sna library you can easily calculate, 

for example, betweenness and closeness centralities (just type betweenness(sna) or 

closeness(sna) in the console and press enter). You can also calculate other graph theoretic 

parameters available in sna library for the spatial configuration concerned. 
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You can import any spatial data produced by employing computer assisted drawing 

(CAD) software programs to FOSS4GIS by converting the respective data first into a 

“.dxf” (drawing exchange format) file and then importing the resulting file to FOSS4GIS 

that you prefer to use via the module or option available for the respective task. SSA 

plugin for FOSS4GIS are particularly designed to be operational for the exchange of data 

between GIS and SNA software programs in which a wide range of network parameters 

can easily be calculated thanks to their specific focus on graph theoretical analysis. 

 

Although users of the plugin are assumed to know the basic knowledge about GIS, it 

would be helpful to describe how they can produce thematic maps (see Figure 1 – 9 for 

some examples from Siteler, an industrial cluster in Ankara) in GIS by using the 

parameters calculated by SSA Plugin in each FOSS4GIS. In this respect, Table 4 shows 

the menu items or mouse button through which you can produce thematic maps for 

different fields (parameters) available in an attribute table: 

 

Table 4. Menu and mouse button path to produce thematic maps in different FOSS4GIS: 

 

FOSS4GIS Menu and mouse button path to produce thematic maps 

OpenJUMP  

Press the right button of the mouse while the cursor is on the name of the layer, 

and then select “Change Styles → Colour Theming”. Check “Enable colour 

theming” and choose among the options available for both “Classification 

Method” and “Attribute” (i.e. parameters). 

gvSIG  

Press the right button of the mouse while the cursor is on the name of the layer, 

and then select “Properties… → Symbology → Quantities → Intervals”. 

Choose among the options available for both “Interval type” and “Classification 

field” (i.e. parameters). 

Thuban 
“Layer → Properties”, and then select a “Field” (parameter) and press 

“Generate Class” 

OpenEV 

On the toolbar click “Classify Layer” tool, and then you can select the field 

(parameter) for thematic map. Press “reclassify…” in order to choose among 

the options available for classification “Type”.  

Quantum GIS 
“Layer → Properties…”, and then select “Style” tab and “Graduated” option for 

the classification. Select the parameters from the available “Column”s. 
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Table 4. Menu and mouse button path to produce thematic maps in different FOSS4GIS 

(continued from above): 

 

FOSS4GIS Menu and mouse button path to produce thematic maps 

MapWindow GIS 

“Layer → Properties”, and then select “Categories” tab and uncheck “Unique 

values”. Select the parameters from the available “Fields” and press “Generate” 

in order to classify the values. 

SAGA GIS 

Activate “Show Object Properties” via “Window” menu. And then select 

“Colors → Type → Graduated Color” and define the parameter via “Colors → 

Type → Graduated Color → Attribute”. 

OrbisGIS 

Press the right button of the mouse while the cursor is on the name of the layer, 

and then select “Edit Legend”. And then press “Add” tool and select “Interval 

classification”. Define “Classification field:” (parameter) and “Type of 

interval:”. 

R Project 

Script automatically produces a thematic for the global integration values. 

Please refer to R manuals and also analyze the script to see how to produce 

alternative thematic maps. 

 

Lastly, as this user’s guide is not intended to provide users with some knowledge about 

how to use a GIS software program, if you are unfamiliar with GIS programs, you will 

need to search for a simple user’s guide for FOSS4GIS you prefer to use in order to, at 

least, to open or load a vector layer into FOSS4GIS. Nevertheless, most of the time the 

respective procedure is very simple for the majority of FOSS4GIS and you can easily 

explore how to add a vector layer to the program. You may obtain information about a 

general user guide for FOSS4GIS you prefer to use via the following links; 

 

Table 5. Links for FOSS4GIS  

 

FOSS4GIS link FOSS4GIS link 

OpenJUMP  http://www.openjump.org/ MapWindow http://www.mapwindow.org/ 

gvSIG  http://www.gvsig.org/web/ OrbisGIS http://www.orbisgis.org/ 

Thuban http://thuban.intevation.org/ R Project http://www.r-project.org/ 

OpenEV http://openev.sourceforge.net/ 

Quantum GIS http://www.qgis.org/ 

SAGA GIS 
http://www.saga-

gis.org/en/index.html 
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Figure 1. A thematic map produced in OpenJUMP for Global Integration values. 

 

 
 

Figure 2. A thematic map produced in Quantum GIS for Global Integration values. 
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Legend 
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Figure 3. A thematic map produced in Thuban for Global Integration values. 

 

 
 

Figure 4. A thematic map produced in OpenEV for Global Integration values. 
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Figure 5. A thematic map produced in gvSIG for Global Integration values. 

 

 
 

Figure 6. A thematic map produced in SAGA GIS for Global Integration values. 
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Figure 7. A thematic map produced in MapWindow GIS for Global Integration values. 

 

 
 

Figure 8. A thematic map produced in OrbisGIS for Global Integration values. 
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Figure 9. A thematic map produced in R Project for Global Integration values. 

 

 

References 

 

Hillier, B. and Hanson, J. (2003) The social logic of space, Cambridge: Cambridge 

University Press. 

 

Beyhan, B. (2011) “Developing Space Syntax Tools for Free and Open Source Software 

for GIS”, in Proceedings of the 19th International Conference on Geoinformatics 

(Geoinformatics 2011), Shanghai, China. 

 

Beyhan, B. (2012) “Developing Graph Theoretic Analysis Tools in FOSS4GIS: An 

Experiment in OpenJUMP with a Specific Focus on Space Syntax”, FOSS4G-CEE and 

Geoinformatics, Prague 2012. 

 



 16 

Butts, C.T. (2010) The sna Package: Tools for Social Network Analysis, available on the 

internet, URL http://erzuli.ss.uci.edu/R.stuff (last accessed at 18.06.2012). 

 

 

 

download link for this guide: http://mekandizim.mersin.edu.tr/belgeler/SSA-IUG.pdf 

 

download link for SSA Plugins:: http://mekandizim.mersin.edu.tr/ 

 

 



 17 

GUIs of the plugin in different FOSS4GIS are presented below; 

 

OpenJUMP BeanShell and Jython plugin OpenJUMP Java (jar) plugin 

  
 

 

gvSIG Jython GUI and plugin gvSIG xml GUI and Jython plugin 
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Thuban Python plugin OpenEV Python plugin 

  
 

 

Quantum GIS Python plugin MapWindow GIS VB.Net plugin 
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OrbisGIS BeanShell Script plugin R Project R Script plugin 

 

 
 

In R Project, no option is actually needed 

for the creation of an external network 

data and geodesic matrix as in R you can 

conduct social network analysis using sna 

package and calculate many other graph 

theoretic parameters thanks to the 

availability of a wide range of packages. 

 

SAGA GIS C++ plugin 

 
 


